There is no Enclosure icon on the Touchscreen when the Enclosure is plugged in.
Possible Causes
- The firmware is outdated.
- The Expansion Cable for the Enclosure is broken.
- The Enclosure Port of the Controller is broken.
Actions
1. Download and install the latest firmware.
2. If the problem persists, use a multimeter to measure the output of the Controller.
2.1 Unplug the Expansion Cable from the Enclosure and leave the other end plugged into the Enclosure Port of the Controller.
2.2 Turn on the machine. Measure the voltage of the pins shown below with a multimeter.
- The voltage between Pin 1 and Pin 4 should be around 24V.
- The voltage between Pin 1 and Pin 2 should be around 2.2V.
- The voltage between Pin 1 and Pin 3 should be around 2.2V.
Pay attention to avoid connecting Pin 4 and Pin 2 (or Pin 3). Otherwise, the Controller will be damaged due to a short circuit.
After that, please contact us at support@snapmaker.com with your test results. We will help you with further troubleshooting.